Strike Status Page

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Settlement Delays: US Deposits and Bill Pay
Resolved·Degraded performance

The issue with our Banking Services is now resolved. Apologies for any inconvenience this might have caused.

Fri, Jan 30, 2026, 05:06 PM
(3 months ago)
·
Affected components
Jan 30, 2026, 11:48 AM
05:06 PM
Banking Services
Updates

Resolved

The issue with our Banking Services is now resolved. Apologies for any inconvenience this might have caused.

Fri, Jan 30, 2026, 05:06 PM

Investigating

We are currently experiencing a service disruption with our external provider that is affecting settlement times for US-based banking services.

Scope of Impact:

  • Individual Accounts (US): All incoming deposits (including paychecks) and outgoing Bill Pay transactions may take longer than usual to settle.

  • Business Accounts (US): A limited number of business ACH deposits may also experience delays.

Current Status: Our engineering team is engaged with our provider to resolve these delays. Your funds are secure, and we are working to ensure they settle as quickly as possible. We will provide another update once we have more details.

Fri, Jan 30, 2026, 11:48 AM(5 hours earlier)