Resolved
The issue with our Banking Services is now resolved. Apologies for any inconvenience this might have caused.
Monitoring
We have identified and fixed the underlying issue. We are monitoring the system behaviour.
Investigating
We are aware of issues with some of our Banking Services and we are in the process of investigating. We will be writing a further update as soon as we can share more details.