Strike Status Page

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Accounts Paused
Resolved·Degraded performance

This issue related to accounts being incorrectly paused has been identified and resolved. Please close and re-open your Strike app.

Wed, Apr 8, 2026, 02:10 AM
(5 months ago)
·
Affected components
Apr 8, 2026, 01:37 AM
02:10 AM
Strike App (Android)
Strike App (iOS)
Strike Dashboard (dashboard.strike.me)
Updates

Resolved

This issue related to accounts being incorrectly paused has been identified and resolved. Please close and re-open your Strike app.

Wed, Apr 8, 2026, 02:10 AM

Investigating

We are aware of issues affecting some users accounts being incorrectly paused. We are working to resolve this issue.

Wed, Apr 8, 2026, 01:37 AM(32 minutes earlier)