Strike Status Page

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Banking Services issues
Resolved·Degraded performance

Issues with our European banking partner have been resolved.

Wed, May 20, 2026, 06:26 PM
(3 hours ago)
·
Affected components
May 19, 2026, 02:55 PM
May 20, 2026, 06:26 PM
Banking Services
Updates

Resolved

Issues with our European banking partner have been resolved.

Wed, May 20, 2026, 06:26 PM

Monitoring

Our European banking partner is experiencing delays in processing SEPA Instant Payments. Deposits and withdrawals will be queued until the issue is resolved.
We are actively monitoring the situation and will update our status page as soon as the issue is resolved.

Tue, May 19, 2026, 02:55 PM(1 day earlier)