Resolved
Strike.me website and Dashboard are operational again.
Identified
Some customers may be experiencing intermittent issues accessing the Strike.me website and Dashboard. Our team is actively working with our third-party partner to resolve the issue as quickly as possible. The Strike app and other core services, including buying bitcoin, remain fully operational.