Service disruption
Resolved·Partial outage

All services are back to operational.

Fri, Feb 28, 2025, 07:25 PM
(7 months ago)
·
Affected components
Banking Services
Bitcoin Payments: Lightning
Bitcoin Payments: On-Chain
Bitcoin Withdrawals
Buy Bitcoin
Exchange Rates
Onboarding & KYC
Send Globally
Strike API
Updates

Resolved

All services are back to operational.

Fri, Feb 28, 2025, 07:25 PM

Investigating

We’re currently experiencing a service disruption, some services are temporarily unavailable. Our team is actively working to resolve the issue as quickly as possible.We’ll provide updates here as soon as we have more information. Thanks for your patience!

Fri, Feb 28, 2025, 06:49 PM(35 minutes earlier)