Strike application issues
Resolved·Full outage

Strike services have fully recovered, and normal operation has resumed.

Thu, Feb 5, 2026, 04:53 PM
(12 hours ago)
·
Affected components
Banking Services
Bitcoin Payments: Lightning
Bitcoin Payments: On-Chain
Bitcoin Withdrawals
Buy Bitcoin
Exchange Rates
Onboarding & KYC
Send Globally
Strike App (Android)
Strike App (iOS)
Strike API
Strike OAuth Connect
Strike Dashboard (dashboard.strike.me)
Updates

Resolved

Strike services have fully recovered, and normal operation has resumed.

Thu, Feb 5, 2026, 04:53 PM

Identified

We are starting to see services recovering, and are monitoring for additional performance issues.

Thu, Feb 5, 2026, 04:43 PM(10 minutes earlier)

Investigating

We are aware of issues with using Strike app and we are in the process of investigating. We will be writing a further update as soon as we can share more details.

Thu, Feb 5, 2026, 04:21 PM(22 minutes earlier)