Buy Bitcoin
Incident Report for Strike
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 13:08 UTC
Monitoring
The issue has been identified and solved accordingly.
We are monitoring system behavior.
Posted Feb 09, 2024 - 12:39 UTC
Investigating
We are aware of issues with our Buy Bitcoin service and we are in the process of investigating. We will provide an update as soon as we have more details to share.
Posted Feb 09, 2024 - 11:53 UTC
This incident affected: Bitcoin Payments: Lightning, Bitcoin Payments: On-chain, Buy Bitcoin, Send Globally, and Strike Dashboard.