Onboarding & KYC issues
Incident Report for Strike
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 20:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2022 - 20:19 UTC
Investigating
We are aware of delays during Onboarding & KYC and are in the process of investigating. We're working as quickly as possible to assess all accounts in the order in which they were received.

Please expect to hear from us should additional information be required to onboard your account.
Posted Nov 15, 2022 - 20:05 UTC
This incident affected: Onboarding & KYC.