Bitcoin Withdrawals issues
Incident Report for Strike
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 19:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2022 - 10:11 UTC
Investigating
We are aware of issues with Bitcoin Withdrawals and we are in the process of investigating. We will be writing a further update as soon as we can share more details.
Posted Nov 22, 2022 - 10:05 UTC
This incident affected: Bitcoin Withdrawals.