Bitcoin Withdrawals issues
Incident Report for Strike
Resolved
This incident has been resolved.
Posted Nov 20, 2022 - 23:39 UTC
Investigating
We are aware of issues with Bitcoin Withdrawals and we are in the process of investigating. We will be writing a further update as soon as we can share more details.
Posted Nov 20, 2022 - 23:36 UTC
This incident affected: Bitcoin Withdrawals.