Bitcoin Withdrawals Issues
Incident Report for Strike
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 01:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2023 - 01:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 20, 2023 - 00:46 UTC
Investigating
We are aware of issues with Bitcoin Withdrawals and we are in the process of investigating. We will be writing a further update as soon as we can share more details.
Posted Jan 19, 2023 - 22:23 UTC
This incident affected: Bitcoin Withdrawals.